Go Back   Savage 2: A Tortured Soul Forum > Savage 2 Modding > Released Projects

Notices

Released Projects Share your finished/beta modifications with the community!

Reply
 
Thread Tools Display Modes
Old 02-28-2010, 08:08 PM   #1
t1ck

 
Join Date: Mar 2008
Posts: 371
Thanks: 0
Thanked 1 Time in 1 Post
Default Extra options

the screenshot should explain everything


download:
http://home.arcor.de/ognas/s2/resour...traOptions.s2z
mirror:
http://winex.org/pub/games/savage2/mods/resources81.s2z

feel free to modify and share

UPDATE:
go straight to winex post and get the latest version there!
http://forums.savage2.com/showpost.p...8&postcount=35

UPDATE: new url and name for the file. my rapidshare account has expired :/

Last edited by t1ck; 09-15-2011 at 09:28 PM.
t1ck is offline   Reply With Quote
Old 03-01-2010, 11:55 PM   #2
Morpheius

 
Join Date: Aug 2009
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Awesome work t1ck you did it thanks owe you karma
Morpheius is offline   Reply With Quote
Old 03-02-2010, 07:31 AM   #3
Mascher

 
Join Date: Feb 2007
Posts: 118
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Installation instruction pleas
__________________
******************

Mascher is offline   Reply With Quote
Old 03-02-2010, 11:58 AM   #4
t1ck

 
Join Date: Mar 2008
Posts: 371
Thanks: 0
Thanked 1 Time in 1 Post
Default

just download the s2z file and place it in your savage2 game folder (next to the resources0.s2z)
here are the instructions from another thread:
Quote:
How to install:

Place the downloaded .s2z file in the game directory in the Savage 2 installation:

Linux: /home/<username>/Savage 2/game/
Windows 7: C:\Program Files\Savage 2 - A tortured soul\game\
Windows Vista: C:\Program Files\Savage 2 - A tortured soul\game\
Windows XP: C:\Program Files\Savage 2 - A tortured soul\game\
Mac:
1. Press Finder
2. Press Applications
3. Right click 'Savage 2 - A tortured soul', and press Show containing files
4. Open Game folder
5. Move file here
this should be the right locations when you installed the game without changing the destination folder
t1ck is offline   Reply With Quote
Old 03-02-2010, 12:29 PM   #5
cabecudo

cabecudo's Avatar
 
Join Date: Oct 2008
Posts: 441
Thanks: 31
Thanked 10 Times in 7 Posts
Default

wow nice one T1ck
__________________
Quote:
Originally Posted by Dewey View Post
Another six hours of Xigbar yelling about mortgage rates, car payments, global warming, and whatever other random sh*t Xiggy likes to yell about...


Quote:
Originally Posted by S2stony View Post
I dont know what the fuck you are talking about xigbar.
No one does :(
cabecudo is offline   Reply With Quote
Old 03-02-2010, 11:02 PM   #6
Inoyoulikeme

 
Join Date: May 2009
Location: In the sky with diamonds...
Posts: 5,549
Thanks: 3
Thanked 77 Times in 55 Posts
Default

T1ck, I don't want to cause a problem or anything, but why can't I change the binds permanently from the options menu? It will continue to reset to default after the game is over, also the 'M' bind opens the game stats window briefly, is there a way to fix this?
Inoyoulikeme is offline   Reply With Quote
Old 03-02-2010, 11:48 PM   #7
t1ck

 
Join Date: Mar 2008
Posts: 371
Thanks: 0
Thanked 1 Time in 1 Post
Default

finaly somebody tested this
Quote:
but why can't I change the binds permanently from the options menu? It will continue to reset to default after the game is over
must be a problem with my default configuration not overwritten by the startup.cfg, i have to look into it as soon as i have some spare time.
as a workaround you can delete the game_settings.cfg from the resources81.s2z (its just a zip file)
Quote:
also the 'M' bind opens the game stats window briefly
i read the SF from the ui, somehow they are not refreshed when you are in the game (as a player), so i have to open the stats window for like 30ms to get the most current SF.
if i would not refresh them the stackomat would only tell the correct values while you are in the lobby or looking at the stats.

Last edited by t1ck; 03-02-2010 at 11:50 PM.
t1ck is offline   Reply With Quote
Old 03-03-2010, 06:13 PM   #8
t1ck

 
Join Date: Mar 2008
Posts: 371
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
as a workaround you can delete the game_settings.cfg from the resources81.s2z (its just a zip file)
i removed the file, please test again when you got some spare time
t1ck is offline   Reply With Quote
Old 03-03-2010, 07:37 PM   #9
Inoyoulikeme

 
Join Date: May 2009
Location: In the sky with diamonds...
Posts: 5,549
Thanks: 3
Thanked 77 Times in 55 Posts
Default

Quote:
Originally Posted by t1ck View Post
i removed the file, please test again when you got some spare time
I'll test it now.
Inoyoulikeme is offline   Reply With Quote
Old 03-03-2010, 08:00 PM   #10
Pistolero

Pistolero's Avatar
 
Join Date: Feb 2008
Location: France
Posts: 241
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It took me a lot of time to understand something: You may need to do a "reset to default" in the Binding menu to see the changes and overwrite the startup.cfg file.

Scripts are now working fine by me, but I can not display the UI menu additionnal options. UI is still like before without the chat options. I didnt try with deleting the game_settings.cfg yet.

Edit: sorry for my noobness !! i had a conflict with an old version of wiwi/stanz ui, because i still had in "my document" a game_options.xml file... the new way of mod installation is so simple ! Just put the moded ressourcexx.S2z file in S2 "game" main folder. And it looks compatible with last wiwi master ui.

Edit: so regarding this mod, i can not clear a bind. Bind modification looks to work only partially.
but default settings are well working.

Last edited by Pistolero; 03-03-2010 at 09:08 PM.
Pistolero is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 11:46 PM.